< Back

UK Powernetworks Power Outage affecting Broadband and Voice services in the ME17 Maidstone and Surrounding areas

We are currently experiencing a power outage effecting our equipment for broadband and voice services in the ME17 Maidstone and surrounding area due to a UK PowerNetworks fault.

Their current rectification estimate is around 18.30 - 19.30

Please do not reset your routers

Apologies for the inconvenience caused, and thank you for your patience

UK Power networks resolved the power issues around 20.45 last night, all connections should be back online ok

Once again apologies for the inconvenience caused, and thank you for your patience

Update from UK Powernetworks: 27 Nov 2021 Update from the team

Update at 16:57 - Our engineers have arrived on site in the Lenham ME17 area to investigate the power cut affecting 436 properties. Specialist engineers are also working to divert power remotely, and this can cause your lights to go on and off. We know that the government advice has changed, but we still ask that you socially distance when interacting with our staff. We know that in the current pandemic, a power cut can be especially disruptive, as you may be working from home, or taking care of elderly or unwell family members, and we want to support you however we can. We'll update you with all of our progress